Collections:
Other Resources:
Getting Errors When Starting Apache to Load PHP Module
Why am I getting errors when starting Apache server to load PHP as a module with php5apache2.dll?
✍: FYIcenter
httpd.exe: Syntax error on line 116 of C:/Program Files /Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/php-5.2.0-Win32 /php5apache2.dll into server: The specified module could not be found.
This tutorial explains why and helps you to resolve the issue.
1. Go to the PHP installation directory: C:/Program Files/php-5.2.0-Win32. You will see two files:
11/02/2006 12:41 PM 36,925 php5apache2.dll 11/02/2006 12:41 PM 36,927 php5apache2_2.dll
2. PHP installation guide tells you to use php5apache2.dll. But that's wrong. php5apache2.dll is not compatible with Apache 2.2 on Microsoft Windows. You should use php5apache2_2.dll.
3. Open Apache server configuration file again and change the LoadModule statement as:
LoadModule php5_module "C:/Program Files/php-5.2.0-Win32/php5apache2_2.dll"
PHPIniDir "C:/Program Files/php-5.2.0-Win32"
...
<IfModule mime_module>
...
AddType application/x-httpd-php .php
</IfModule>
4. Start Apache server again. You will no problem now.
2016-07-10, ≈22🔥, 3💬
Popular Posts:
What are the commonly used background processes on Windows systems? - Part II Continue from Part I ....
Downloading and Installing vStrip "vStrip" is one the most powerful DVD ripper and VOB file processi...
How to restore Bluetooth icon in the taskbar (system tray) on Windows 7? I removed it by a mistake. ...
What is YInstStarter Class - Download Program Files (DPF)? YInstStarter Class is a Download Program ...
Where to find tutorials on managing Windows 8 startup programs? Here is a collection of tutorials on...