Requirements for Internet Explorer (IE) 7

Q

What are the requirements for Internet Explorer (IE) 7?

✍: FYIcenter.com

A

If you want to try Internet Explorer (IE) 7, you need to have one of the following versions of Windows systems or better:

Windows XP Service Pack 2 (SP2)
Windows XP Professional x64 Edition
Windows Server 2003 Service Pack 1 (SP1)

 

Starting Home Page for Internet Explorer (IE) 7

Internet Explorer (IE) 7

Internet Explorer (IE) 7

⇑⇑ Internet Explorer Tutorials

2007-02-08, 7602👍, 0💬